Introduction to Virtual Extensible LAN (VXLAN)

By | March 25, 2020

Below is the Introduction to Virtual Extensible LAN – VXLAN.

VXLAN ( Virtual Extended LAN ) is a replacement for traditional VLAN. Because VLAN can provide only maximum 4096 VLANs , due to VLAN ID field size of 12 bits. But VXLAN uses 24 bits for ID field. which is called VXLAN segment or VNI. So in the result, we can configure approximately 16.78 million VXLAN segment.

VXLAN is also solution for spanning-tree. Because spanning-tree can be painful for a big layer 2 data center. VXLAN is a best solution for big data centers which are having ‘n’ number of VMs. Because this type of environment requires the large number of VLAN IDs as well as devices generate big size MAC tables.

VXLAN encapsulates the original frames , broadcast frames , multicast frames and unicast frames. So we can consider it as an tunneling technique or a layer 2 overlay scheme, over layer 3 network.

Tunnel end devices called VTEP Which performs the encapsulation and de-encapsulation.

VXLAN does’t support the fragmentation. So a big size frame can be drop. We should configure jumbo frames / higher MTU to avoid this situation.

VTEP device send the all unknown destination frames , multicast frames or broadcast frames using multicast.

We can also use multicast routing protocols like PIM-SM to make masticating easier.

We can use VXLAN on top switches of racks of data center. VXLAN can also be use to connect multiple data centers. It can also be used for servers , if servers are VXLAN capable or understands the VXLAN technique.

If we are using VXLAN for servers then tunnel end points will be on server. We can also use VXLAN, When multiple servers are connected on a single switch. some servers supporting VXLAN and some are not supporting.

In this case, Switch will be configure as a VXLAN gateway and one end of tunnel will be on server that understands the VXLAN.

VXLAN can also work with VRF.

VXVLAN Packet Format:

Image source is cisco.

VXLAN packet header format

Configuration Example:

VXLAN example

NEXUS-1 Configuration:

feature OSPF
feature vn-segment-vlan-based
feature mv overlay
system jumbomtu 9216
router ospf 10
int e2/2
no switchport
ip add 100.1.1.1/30
ip router ospf 10 area 0
int l0
ip add 10.10.10.10/32
ip router ospf 10 area 0
vlan 50
vn-segment 5000
int e0/0
switchport mode access
switchport access vlan 50
no shut
int nve 1
no shut
source-interface loopback 0
member-vni 5000
ingress-replication protocol static
peer-ip 20.20.20.20

NEXUS-2 Configuration:

feature OSPF
feature vn-segment-vlan-based
feature mv overlay
system jumbomtu 9216
router ospf 10
int e2/2
no switchport
ip add 100.1.1.2/30
ip router ospf 10 area 0
int l0
ip add 20.20.20.20/32
ip router ospf 10 area 0
vlan 50
vn-segment 5000
int e0/0
switchport mode access
switchport access vlan 50
no shut
int nve 1
no shut
source-interface loopback 0
member-vni 5000
ingress-replication protocol static
peer-ip 10.10.10.10

Show commands:

N1# show nve peer detail
N1# show nve vni data plane

I hope , now you have understood VXLAN (Introduction to Virtual Extensible LAN – VXLAN).

Thanks For reading ……………………..

We will recommend you to read below posts:

2 thoughts on “Introduction to Virtual Extensible LAN (VXLAN)

  1. ปั้มไลค์

    Like!! Really appreciate you sharing this blog post.Really thank you! Keep writing.

    Reply
  2. Sandeep

    Thanks Really nicely explained…just one correction there is no any feature of “mv overlay” please correct to “nv overlay”.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *